Serial console connection from your mac using a usb-to- serial adapter

First plug in your usb to serial adapter and find the devicename using the Terminal program, mine is listed here:

ls /dev/tty.*

/dev/tty.usbserial-AH06ORK9

Then start the screen command with the devicename and baudrate

screen /dev/tty.usbserial-AH06ORK9 9600

If you want to keep a log you can do so with

Control-a H

When your finished exit with :

Control-a Control-\    

Thanks Jeff Huckaby at Rackaid for this nice post.

Hits: 4

Blackhole Routing

OK, so you’ve created your ipsec vpn tunnels and added the corresponding static routes, but which path does the VPN traffic take if your tunnel is down ?

Right, it uses the next best route in the routing table and chances are this is your default route pointing to your internet router…

But luckily you did add a blackhole route for this traffic, preventing this:

 

 

 

 

 

So next time your VPN tunnel is down, traffic will be dropped by the Fortigate and not use your default route again.

Or you can use the CLI for this:

config router static
edit 0
set blackhole enable
set dst 172.16.0.0/12
next
end

Hits: 6

Troubleshooting Fortigate using CLI

First check if and how traffic enters the device. Use the filter option.

Using the FortiOS  packet sniffer

Assgined Internet Protocol numbers

Then check the flow through the firewall and find out the policy id

Using debug flow

Find the system session and PolicyID

session info: proto=1 proto_state=00 duration=96 <snip>
misc=0 policy_id=3 auth_info=0 chk_client_info=0 vd=0
<snip>
total session 2

Then use  show firewall policy <id> to list the policy used for the traffic:

FGT60ELexThuis # show firewall policy 3
config firewall policy
edit 3
set name "Lex"
set uuid d42a3556-cb66-51e7-e20b-6be8577def0b
set srcintf "internal"
set dstintf "wan1"
set srcaddr "Lex zolder" "Laptop Lex" "PC Huiskamer"
set dstaddr "all"
set action accept
set schedule "always"
set service "ALL"
set utm-status enable
set logtraffic all
set av-profile "Quick block"
set ips-sensor "protect_client"
set application-list "block-botnet-monitor"
set profile-protocol-options "custom-default"
set ssl-ssh-profile "certificate-inspection"
set nat enable
next
end

 

 

 

Hits: 38

FT8 met WSJT-X en JTAlertX

FT8 is een nieuwe datamode voor radiozendamateurs. Met FT8 kunnen zelfs bij slechte condities QSO’s worden gemaakt. Dit gaat via software die je eerst op je PC moet installeren en instellen. Het meest gebruikte programma voor FT8 is WSJT-X, je kan het hier downloaden.

FT8 werkt via een vaste tijdspatroon, en uitzending duurt iets minder dan 15 seconden en er wordt afwisselend gezonden en ontvangen. Het is dus zeer belangrijk dat de klok in je PC precies gelijk loopt. Dit doe ik met het Meinberg NTP programma, je vind het hier.

Behalve WSJT-X gebruik ik ook JTAlertX. Met dit programma wordt het maken van QSOs makkelijker en na afloop van de verbinding wordt deze automatisch gelogged in mijn log programma.

JTAlertX vind je hier, en Log4OM hier

Al deze software is gratis te gebruiken.

Loggen van QSO via JTALertX werkt ook in combinatie met DXKeeper, HamRadioDeLuxe en ACLog

 

Instellingen WSJT-X

De installatie is eenvoudig, volg de default instellingen, druk een paar keer op Next, dan op Install en Finish.

Na de eerste keer opstarten moeten er nog wat gegevens worden ingevuld onder File>Settings, bij mij staat dit zo:

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Hierna nog even voor FT8 kiezen via het Mode menu.

Instellingen JTAlertX

Ook hier is de installatie weer eenvoudig, selecteer bij Additional Tasks alleen WSJT-X – JTAlertX, en vink de andere vakjes uit.

Nu de instellingen goed zetten, klik op Settings in de titelbalk van het venster.

Hier stel je de koppeling in naar je Log programma, lees vooral ook de helpfile onder de Helpknop voor meer info.

 

 

 

 

 

 

 

 

1e QSO

Start de programma’s, controleer of je set van frequentie wisselt als je op een andere band klikt in WSJT-X.

FT8 werkt het beste als de ontvangen en verzonden audio zo schoon mogelijk is, dus stuur je ALC in je radioset niet over, gebruik geen compressie, noise blankers en een zo groot mogelijke audio bandbreedte (2 a 3 kHz is prima).

Wacht op een CQ aanroep, deze is groen in JTAlertX, dubbelklik op de Call van het tegenstation om aan te roepen.

Je set gaat nu op zenden en stuurt in 15 seconden je Call en Locator. Hierna antwoord de ander in 15 seconden met de door hem ontvangen signaalsterkte van jouw uitzending.

Daarna antwoord jij met zijn signaalsterkte. Hij geeft RRR, we sturen allebei een 73 en het QSO is gemaakt.

Uiteraard valt er nog veel meer te vertellen over FT8, en de software hiervoor, maar voor nu heb je een start met deze nieuwe digitale mode.

Kijk de filmpjes op Youtube en lees de handleiding van WSJT-X voor extra informatie.

Vooral de Hinson Tips zijn zeer de moeite waard als je ook DX stations wilt werken !

 

 

 

Hits: 226

NUC PC for Hamradio

With my PC running when doing hamradio I noticed the level of noise coming from my PC.

My PC looks like this:

It runs fine but the cooling fans generate a constant level of noise that started to annoy me and i started browsing the internet for a more quiet PC.

Intel NUC i3

So after some research on the web I ordered  the Intel NUC (nuc7i3bnh):
Yes, it is really small, those are two usb ports on the front, another two are on the back as well as an HDMI and DC port for the mains adapter.

This PC comes with a CPU but no memory and no harddisk.

Harddisk is the wrong word here, todays hardddisk are solid state, small and look like this:

This one is from Intel (Intel 1607243) and stores 128 Gigabytes of data (yes that is 137.438.953.472 bytes !), much more than I will ever need for this PC !

Next I choose 2 sticks of 4GB RAM memory (Crucial CT2K4G4SFS824A)

 

 

 

 

 

 

Adding the memory and storage to the NUC is super easy, step by step documentation is included, I only needed two philips screwdrivers.

Check the specs here for a complete list of all connectivity (wifi, bluetooth, soundcard, USB-C and more)

Installing the software

After powering up the NUC for the first time, it is ready to boot from  a usb memory stick in order to install the operating system.

Windows 10 pro installed quick with no issues, next I re-installed my applications form my old to my new PC.

N1mm, Log4OM, CW skimmer, HDSDR,  Bandmaster, Omnirig and Office 2016 they all run great.

Typical CPU with N1MM, HDSDR and CW skimmer all up and running is about 20%.

Performance

Time to check the difference in performance. I used the tool Novabench for this.

My old PC runs an Intel I5 CPU vs. an I3 in my newNUC.
Memory is 8 GB DDR4 in both computers
Harddisks are both solid state.

Result: The NUC scores 10% slower than my old pc.

Can I tell the difference ?

A little.

Do I care ?

Not really, he NUC still runs my software fast enough for me, and the noise level has dropped a lot.

Score Old PC:Score New NUC:

Final Thoughts

As you understand by now I really like my new NUC PC.

Today personal computers do not have to be big and loud, this Intel NUC replaces my old PC perfectly.

It has plenty of CPU to run all my apps smoothly.

When ordering I was not sure if 4 usb ports would be enough but this also worked out fine:

I use 1 for my keyboard/mouse, another 1 for my IC-7300 and 1 for my SDRplay, so still 1 left for further expansion.

Installation was easy, total time from installing the hardware, operating system, applications, and restoring my datafiles took about 4 hours.

After installation of all software + 5GB of MP3 files i still have 90 GB disk storage left.

Total cost for NUC, RAM and harddisk E400 with free shipping from www.amazon.de to The Netherlands

Hits: 385

Hamradio Podcasts

Wanneer je een smartphone hebt, kan je die ook gebruiken om naar podcasts te luisteren. Podcasts heb je over allerlei onderwerpen dus ook over hamradio.

Maar voor dat je naar deze ‘radio’-programmaatjes kan luisteren doe je het volgende:

  1. Download een podcastspeler op je telefoon. Hierin kan je de podcasts downloaden en afspelen:
    • Iphone/Ipad: Kies er een uit in de appstore. Zelf heb ik Downcast gekocht en die bevalt mij prima.
    • Android: Zoek je er een uit de google play store bijvoorbeeld Pocket Casts.
  2. Start de app en ga op zoek naar podcasts die je interessant vindt óf importeer de opml-lijst van een ander zoals hier die van mij. (Open de link vanaf je smartphone, dan kan je de lijst meteen inlezen in je podcast speler)
  3. Nu je app weet naar welke podcasts je wilt luisteren moeten deze nog wel worden gedownload  naar je smartphone, In de podcastspeler kan je o.a. instellen hoe vaak je wilt controleren op nieuwe afleveringen,  etcetera….
  4. Bij de meeste podcasts hoort ook een website met meer informatie over wat besproken wordt. Even opzoeken op google of goed luisteren naar de podcast, dan komt de verwjzing naar de website wel voorbij.

Nu ik het over podcasts heb moet ik ook Leo Laporte noemen.

Hij is behalve radiomaker ook techeut en zendamateur W6TWT. Hij produceert al jaren niet alleen audio maar ook video podcasts  over allerlei tech onderwerpen van een constant hoge kwaliteit. Kijk maar eens hier.

En nog een laatste weetje:

Adam Curry wordt ook wel ‘The Podfather’ genoemd omdat een van de eerste met een  podcast The Daily Source Code was. Wist je dat hij ook zendamateur KF5SLN is ?

 


Hits: 154

Fortigate Password recovery

https://docs.fortinet.com/uploaded/files/1708/Resetting_a_lost_admin_password.pdf

via console access 9600,n,8,1:

logon immediately after login prompt with:

username: maintainer

password: bcpbFGT60E4Q16092486

(bcpb+serialnr)

Change old password with:

In a unit where vdoms are not enabled:

config system admin
edit admin
set password <psswrd>
end
In a unit where vdoms are enabled:

config global
config system admin
edit admin
set password <psswrd>
end

 

reset to factory default with:

exec factoryreset

Hits: 26

Fortigate Tips & Tricks

Switch to VDOMs:

GUI:

Dashboard>System>VirtualDomain

CLI:

config system global
  set vdom-admin enable
end

Select Global from GUI and create VDOMS from there,

Set dedicated mgmt port in ROOT vdom via Network>Interfaces

Create VDOMS as needed, add interfaces, configure administrators

Check Cookbook for more info

Hits: 149

Bitx40 CW homebrew

This month I completed the build of a 40m Bitx trx  to take along when on holiday. Output is 5 Watts.

I ordered mine here.

Apart from this you need also need a case.

There is a very active forum on this kit here.

The kit is SSB only, no CW. BUT Jerry – KE7ER – posted his CW mod in the forum so now mine can do CW as well. Thanks Jerry !

The VFO is made around an Arduino Nano and a Si5351A chip, the combo is called Raduino and ready to use.

The Raduino comes with v1.01 installed. On the forum Allard PE1NWL – posted  v1.09 in which he implemented

  • switch between VFO a and B,
  • use RIT,
  • switch between USB and LSB,
  • easily calibrate the VFO for both sidebands.

Thanks Allard !

I also installed an CW audio filter, i ordered this one

After building everything in the box, the unit received o.k. but had no output power.  Transistor Q13 turned out to be defective.

Luckily we have a small electronic parts shop here in Harderwijk with a great selection of all sort of components and a guy who knows his stuff, so a replacement transistor was no problem.

 

 

 

 

Teun the owner also had a retro handmike in his shopwindow.

For 2 euros you can’t go wrong…

After replacing the tranistor the output power was 5 Watts, enough for most european QSO’s.

 

All in all it was fun to assemble, and is fun to operate.

Hits: 515

Ping sweep using command line

FOR /L %i in (1,1,255) do @ping -n 1 172.17.1.%i | find “TTL”

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.
C:\Users\llu> FOR /L %i in (1,1,255) do @ping -n 1 172.17.1.%i | find “TTL”
Reply from 172.17.1.1: bytes=32 time=1ms TTL=255
Reply from 172.17.1.4: bytes=32 time=1ms TTL=255
Reply from 172.17.1.34: bytes=32 time<1ms TTL=128
Reply from 172.17.1.41: bytes=32 time<1ms TTL=128
Reply from 172.17.1.46: bytes=32 time<1ms TTL=128
Reply from 172.17.1.49: bytes=32 time<1ms TTL=128
Reply from 172.17.1.51: bytes=32 time<1ms TTL=128
Reply from 172.17.1.56: bytes=32 time=6ms TTL=128
Reply from 172.17.1.58: bytes=32 time=10ms TTL=128
Reply from 172.17.1.60: bytes=32 time<1ms TTL=128
Reply from 172.17.1.67: bytes=32 time<1ms TTL=128
Reply from 172.17.1.68: bytes=32 time<1ms TTL=128
Reply from 172.17.1.76: bytes=32 time<1ms TTL=128
Reply from 172.17.1.79: bytes=32 time<1ms TTL=128
Reply from 172.17.1.84: bytes=32 time<1ms TTL=128
Reply from 172.17.1.86: bytes=32 time<1ms TTL=128
Reply from 172.17.1.88: bytes=32 time<1ms TTL=128
Reply from 172.17.1.93: bytes=32 time<1ms TTL=128
Reply from 172.17.1.94: bytes=32 time<1ms TTL=128
Reply from 172.17.1.95: bytes=32 time=1ms TTL=128
Reply from 172.17.1.96: bytes=32 time=2ms TTL=128

 

Hits: 85