ospf for xtm 5 – vlan tagging

create vlan interface, add vlans w. ip’s

modify dynamic routing textfile:

# authentication for this interface:
interface vlan4
ip ospf authentication-key pqr4now
# start ospf
router ospf
# advertise these networks:
network 192.168.101.0/24 area 0.0.0.0
network 192.168.102.0/24 area 0.0.0.0
network 192.168.4.0/24 area 0.0.0.0
# do not listen for ospf packets on these interfaces:
passive-interface eth0
passive-interface eth2
passive-interface eth3
# enable authentication for this area
area 0.0.0.0 authentication
# advertise default route
default-information originate

Check routingtables:

r2#sh ip route ospf
O    192.168.102.0/24 [110/11] via 192.168.4.254, 00:08:20, FastEthernet0/0.4
O    192.168.2.0/24 [110/2] via 192.168.3.254, 00:08:20, FastEthernet0/0.3
O    192.168.101.0/24 [110/11] via 192.168.4.254, 00:08:20, FastEthernet0/0.4
O*E2 0.0.0.0/0 [110/10] via 192.168.4.254, 00:08:20, FastEthernet0/0.4
r2#
WG#sh route
Destination       Gateway           Flags  Metric Ref  Use Iface
1.1.1.0/30        *                 U      0      0      0 eth6.999
192.168.101.0/24  *                 U      0      0      0 vlan101
192.168.102.0/24  *                 U      0      0      0 vlan102
192.168.4.0/24    *                 U      0      0      0 vlan4
192.168.3.0/24    192.168.4.253     UG     11     0      0 vlan4
192.168.2.0/24    192.168.4.253     UG     12     0      0 vlan4
127.0.0.0/24      *                 U      0      0      0 lo
default           1.1.1.2           UG     0      0      0 eth6.999
default           1.1.1.2           UG     50     0      0 eth6.999
Special routing tables
------------
eth6.999.out:
1.1.1.0/30 dev eth6.999  scope link  metric 1
default via 1.1.1.2 dev eth6.999  metric 1
zebra:
192.168.3.0/24 via 192.168.4.253 dev vlan4  metric 11
192.168.2.0/24 via 192.168.4.253 dev vlan4  metric 12
 

Hits: 6

ospf for xtm 3 – show ip route

r1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is 192.168.2.253 to network 0.0.0.0
O    192.168.4.0/24 [110/2] via 192.168.3.253, 00:38:00, FastEthernet0/0.3
O    192.168.102.0/24 [110/12] via 192.168.3.253, 00:38:00, FastEthernet0/0.3
C    192.168.2.0/24 is directly connected, FastEthernet0/0.2
C    192.168.3.0/24 is directly connected, FastEthernet0/0.3
O    192.168.101.0/24 [110/11] via 192.168.2.253, 00:38:00, FastEthernet0/0.2
O*E2 0.0.0.0/0 [110/10] via 192.168.2.253, 00:35:48, FastEthernet0/0.2
r1#
r2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is 192.168.4.253 to network 0.0.0.0
C    192.168.4.0/24 is directly connected, FastEthernet0/0.4
O    192.168.102.0/24 [110/11] via 192.168.4.253, 00:38:38, FastEthernet0/0.4
O    192.168.2.0/24 [110/2] via 192.168.3.254, 00:38:38, FastEthernet0/0.3
C    192.168.3.0/24 is directly connected, FastEthernet0/0.3
O    192.168.101.0/24 [110/11] via 192.168.4.253, 00:38:38, FastEthernet0/0.4
O*E2 0.0.0.0/0 [110/10] via 192.168.4.253, 00:36:25, FastEthernet0/0.4
r2#
xtm2:
WG#sh route
Destination       Gateway           Flags  Metric Ref  Use Iface
10.0.4.0/24       *                 U      0      0      0 eth4
10.0.5.0/24       *                 U      0      0      0 eth5
192.168.101.0/24  *                 U      0      0      0 eth2
192.168.102.0/24  192.168.2.254     UG     22     0      0 eth1
192.168.4.0/24    192.168.2.254     UG     12     0      0 eth1
192.168.3.0/24    192.168.2.254     UG     11     0      0 eth1
192.168.2.0/24    *                 U      0      0      0 eth1
10.0.3.0/24       *                 U      0      0      0 eth3
192.168.200.0/24  *                 U      0      0      0 eth0
127.0.0.0/24      *                 U      0      0      0 lo
default           192.168.200.254   UG     0      0      0 eth0
default           192.168.200.254   UG     50     0      0 eth0
Special routing tables
------------
eth0.out:
192.168.200.0/24 dev eth0  scope link  metric 1
default via 192.168.200.254 dev eth0  metric 1
zebra:
192.168.102.0/24 via 192.168.2.254 dev eth1  metric 22
192.168.4.0/24 via 192.168.2.254 dev eth1  metric 12
192.168.3.0/24 via 192.168.2.254 dev eth1  metric 11
XTM5:
WG#sh route
Destination       Gateway           Flags  Metric Ref  Use Iface
1.1.1.0/30        *                 U      0      0      0 eth0
192.168.101.0/24  *                 U      0      0      0 eth2
192.168.102.0/24  *                 U      0      0      0 eth3
192.168.4.0/24    *                 U      0      0      0 eth1
192.168.3.0/24    192.168.4.254     UG     11     0      0 eth1
192.168.2.0/24    192.168.4.254     UG     12     0      0 eth1
127.0.0.0/24      *                 U      0      0      0 lo
default           1.1.1.2           UG     0      0      0 eth0
default           1.1.1.2           UG     50     0      0 eth0
Special routing tables
------------
eth0.out:
1.1.1.0/30 dev eth0  scope link  metric 1
default via 1.1.1.2 dev eth0  metric 1
zebra:
192.168.3.0/24 via 192.168.4.254 dev eth1  metric 11
192.168.2.0/24 via 192.168.4.254 dev eth1  metric 12
 
 

Hits: 8

ospf for xtm 2 – xtm dynamic routing configs

xtm2:

interface eth1
ip ospf authentication-key pqr4now
router ospf
network 192.168.2.0/24 area 0.0.0.0
network 192.168.101.0/24 area 0.0.0.0
passive-interface eth2
area 0.0.0.0 authentication
default-information originate

xtm5:

# authentication for this interface:
interface eth1
ip ospf authentication-key pqr4now
# start ospf
router ospf
# advertise these networks:
network 192.168.101.0/24 area 0.0.0.0
network 192.168.102.0/24 area 0.0.0.0
network 192.168.4.0/24 area 0.0.0.0
# do not listen for ospf packets on these interfaces:
passive-interface eth0
passive-interface eth2
passive-interface eth3
# enable authentication for this area
area 0.0.0.0 authentication
# advertise default route
default-information originate

Hits: 11

ospf for xtm 1 – router configs

config r1:

interface FastEthernet0/0.2
 encapsulation dot1Q 2
 ip address 192.168.2.254 255.255.255.0
 ip ospf authentication
 ip ospf authentication-key pqr4now
!
interface FastEthernet0/0.3
 encapsulation dot1Q 3
 ip address 192.168.3.254 255.255.255.0
 ip ospf authentication
 ip ospf authentication-key pqr4now
!
router ospf 10
 log-adjacency-changes
 network 192.168.2.0 0.0.0.255 area 0
 network 192.168.3.0 0.0.0.255 area 0
!

config r2:

interface FastEthernet0/0.3
 encapsulation dot1Q 3
 ip address 192.168.3.253 255.255.255.0
 ip ospf authentication
 ip ospf authentication-key pqr4now
!
interface FastEthernet0/0.4
 encapsulation dot1Q 4
 ip address 192.168.4.254 255.255.255.0
 ip ospf authentication
 ip ospf authentication-key pqr4now
!
router ospf 11
 log-adjacency-changes
 network 192.168.3.0 0.0.0.255 area 0
 network 192.168.4.0 0.0.0.255 area 0
!

 

Hits: 129